aboutsummaryrefslogtreecommitdiff
path: root/common/gita.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/gita.nix')
-rw-r--r--common/gita.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/common/gita.nix b/common/gita.nix
new file mode 100644
index 0000000..9dee562
--- /dev/null
+++ b/common/gita.nix
@@ -0,0 +1,17 @@
+_: {
+ # enable programs
+ programs = {
+ git = {
+ enable = true;
+ userName = "rubiigen";
+ userEmail = "alyxwren@proton.me";
+ extraConfig = {
+ commit.gpgsign = true;
+ gpg.format = "ssh";
+ user.signingkey = "~/.ssh/id_ed25519.pub";
+ init.defaultBranch = "master";
+ };
+ };
+ # ... add more programs as you see fit
+ };
+}