aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorFrankie B <git@diskfloppy.me>2023-04-25 20:21:03 +0100
committerFrankie B <git@diskfloppy.me>2023-04-25 20:21:03 +0100
commit4b0c88736979fe2cb8e98e8e0ae12caf7e876141 (patch)
treea3ddb2df189c952758b7b84c593738c154869777 /shell.nix
Add config
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..9525915
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,10 @@
+# Shell for bootstrapping flake-enabled nix and home-manager
+# You can enter it through 'nix develop' or (legacy) 'nix-shell'
+
+{ pkgs ? (import ./nixpkgs.nix) { } }: {
+ default = pkgs.mkShell {
+ # Enable experimental features without having to specify the argument
+ NIX_CONFIG = "experimental-features = nix-command flakes";
+ nativeBuildInputs = with pkgs; [ nix home-manager git ];
+ };
+}