aboutsummaryrefslogtreecommitdiff
path: root/nixos/hosts/nixbox/configuration.nix
diff options
context:
space:
mode:
authorNotAShelf <itsashelf@gmail.com>2023-04-25 23:10:57 +0300
committerGitHub <noreply@github.com>2023-04-25 21:10:57 +0100
commit243a9339f041f62c1b5d8c05b415b126349c95b5 (patch)
tree315d2fafb2ed592e13ebd299f31fcd5d74e2127e /nixos/hosts/nixbox/configuration.nix
parent4b0c88736979fe2cb8e98e8e0ae12caf7e876141 (diff)
reflopactor (#1)
Diffstat (limited to 'nixos/hosts/nixbox/configuration.nix')
-rw-r--r--nixos/hosts/nixbox/configuration.nix140
1 files changed, 0 insertions, 140 deletions
diff --git a/nixos/hosts/nixbox/configuration.nix b/nixos/hosts/nixbox/configuration.nix
deleted file mode 100644
index 9897d25..0000000
--- a/nixos/hosts/nixbox/configuration.nix
+++ /dev/null
@@ -1,140 +0,0 @@
-# Edit this configuration file to define what should be installed on
-# your system. Help is available in the configuration.nix(5) man page
-# and in the NixOS manual (accessible by running ‘nixos-help’).
-{
- config,
- pkgs,
- ...
-}: {
- imports = [
- # Include the results of the hardware scan.
- ./hardware-configuration.nix
- ];
-
- # Bootloader.
- boot.loader.systemd-boot.enable = true;
- boot.loader.efi.canTouchEfiVariables = true;
- boot.loader.efi.efiSysMountPoint = "/boot/efi";
-
- networking.hostName = "nixbox"; # Define your hostname.
- # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
-
- # Configure network proxy if necessary
- # networking.proxy.default = "http://user:password@proxy:port/";
- # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
-
- # Enable networking
- networking.networkmanager.enable = true;
-
- # Set your time zone.
- time.timeZone = "Europe/London";
-
- # Select internationalisation properties.
- i18n.defaultLocale = "en_GB.UTF-8";
-
- i18n.extraLocaleSettings = {
- LC_ADDRESS = "en_GB.UTF-8";
- LC_IDENTIFICATION = "en_GB.UTF-8";
- LC_MEASUREMENT = "en_GB.UTF-8";
- LC_MONETARY = "en_GB.UTF-8";
- LC_NAME = "en_GB.UTF-8";
- LC_NUMERIC = "en_GB.UTF-8";
- LC_PAPER = "en_GB.UTF-8";
- LC_TELEPHONE = "en_GB.UTF-8";
- LC_TIME = "en_GB.UTF-8";
- };
-
- # Enable the X11 windowing system.
- services.xserver.enable = true;
-
- # Enable the KDE Plasma Desktop Environment.
- services.xserver.displayManager.sddm.enable = true;
- services.xserver.desktopManager.plasma5.enable = true;
-
- # Configure keymap in X11
- services.xserver = {
- layout = "us";
- xkbVariant = "";
- };
-
- # Enable experimental features
- nix.settings.extra-experimental-features = ["flakes" "nix-command"];
-
- # Enable CUPS to print documents.
- services.printing.enable = true;
-
- # Enable sound with pipewire.
- sound.enable = true;
- hardware.pulseaudio.enable = false;
- security.rtkit.enable = true;
- services.pipewire = {
- enable = true;
- alsa.enable = true;
- alsa.support32Bit = true;
- pulse.enable = true;
- # If you want to use JACK applications, uncomment this
- #jack.enable = true;
-
- # use the example session manager (no others are packaged yet so this is enabled by default,
- # no need to redefine it in your config for now)
- #media-session.enable = true;
- };
-
- services.xserver.videoDrivers = ["nvidia" "intel"];
-
- # Enable touchpad support (enabled default in most desktopManager).
- # services.xserver.libinput.enable = true;
-
- # Define a user account. Don't forget to set a password with ‘passwd’.
- users.users.floppydisk = {
- isNormalUser = true;
- description = "Frankie B.";
- extraGroups = ["networkmanager" "wheel"];
- packages = with pkgs; [
- firefox
- kate
- # thunderbird
- ];
- initialPassword = "changeme";
- };
-
- # Allow unfree packages
- nixpkgs.config.allowUnfree = true;
-
- # List packages installed in system profile. To search, run:
- # $ nix search wget
- environment.systemPackages = with pkgs; [
- vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
- wget
- git
- gnupg
- pinentry
- ];
-
- # Some programs need SUID wrappers, can be configured further or are
- # started in user sessions.
- # programs.mtr.enable = true;
- # programs.gnupg.agent = {
- # enable = true;
- # enableSSHSupport = true;
- # };
-
- # List services that you want to enable:
-
- # Enable the OpenSSH daemon.
- services.openssh.enable = true;
-
- # Open ports in the firewall.
- # networking.firewall.allowedTCPPorts = [ ... ];
- # networking.firewall.allowedUDPPorts = [ ... ];
- # Or disable the firewall altogether.
- networking.firewall.enable = false;
-
- # This value determines the NixOS release from which the default
- # settings for stateful data, like file locations and database versions
- # on your system were taken. It‘s perfectly fine and recommended to leave
- # this value at the release version of the first install of this system.
- # Before changing this value read the documentation for this option
- # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
- system.stateVersion = "22.11"; # Did you read the comment?
-}