aboutsummaryrefslogtreecommitdiff
path: root/hosts/nixpad/hardware-configuration.nix
diff options
context:
space:
mode:
authorFrankie B <git@diskfloppy.me>2024-02-07 01:43:09 +0000
committerFrankie B <git@diskfloppy.me>2024-02-07 01:43:09 +0000
commitd6e36dfa8e283af33d1f79f173502f505ae83ba7 (patch)
tree450b2da2144f92334edeb2f3cfd6c4ce2cd00a8c /hosts/nixpad/hardware-configuration.nix
parent417c45b85d060dd60741f6c65a335e91edfced40 (diff)
Update h/w config
Diffstat (limited to 'hosts/nixpad/hardware-configuration.nix')
-rw-r--r--hosts/nixpad/hardware-configuration.nix50
1 files changed, 22 insertions, 28 deletions
diff --git a/hosts/nixpad/hardware-configuration.nix b/hosts/nixpad/hardware-configuration.nix
index 3588111..bf0bc0a 100644
--- a/hosts/nixpad/hardware-configuration.nix
+++ b/hosts/nixpad/hardware-configuration.nix
@@ -1,45 +1,39 @@
# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
-{
- config,
- lib,
- pkgs,
- modulesPath,
- ...
-}: {
- imports = [
- (modulesPath + "/installer/scan/not-detected.nix")
- ];
+{ config, lib, pkgs, modulesPath, ... }:
- boot.initrd.availableKernelModules = ["xhci_pci" "nvme" "uas" "sd_mod" "rtsx_usb_sdmmc"];
- boot.initrd.kernelModules = [];
- boot.kernelModules = ["kvm-intel"];
- boot.extraModulePackages = [];
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
- fileSystems."/" = {
- device = "/dev/disk/by-uuid/81d5eb4d-ed55-446c-8c99-048dfb214f9d";
- fsType = "ext4";
- };
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ata_piix" "usb_storage" "sd_mod" "sdhci_pci" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
- boot.initrd.luks.devices."luks-6251bba4-3361-4923-8d83-812cc3162b3e".device = "/dev/disk/by-uuid/6251bba4-3361-4923-8d83-812cc3162b3e";
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/82b7f887-2059-45ae-9bdd-60082718d922";
+ fsType = "ext4";
+ };
- fileSystems."/boot" = {
- device = "/dev/disk/by-uuid/89AE-5193";
- fsType = "vfat";
- };
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/C630-E94C";
+ fsType = "vfat";
+ };
- swapDevices = [
- {device = "/dev/disk/by-uuid/d3f0c084-4a4d-4175-a0e6-94fbe8459614";}
- ];
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/3ce61b0c-691d-4452-93f2-e64e4b926f30"; }
+ ];
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
# (the default) this is the recommended approach. When using systemd-networkd it's
# still possible to use this option, but it's recommended to use it in conjunction
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
- # networking.interfaces.wlp0s20f3.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp0s25.useDHCP = lib.mkDefault true;
+ # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;