aboutsummaryrefslogtreecommitdiff
path: root/hosts/nixpad/hardware-configuration.nix
diff options
context:
space:
mode:
authorrubiigen <alyxwren@proton.me>2024-02-02 18:29:45 +0000
committerFrankie B <frankieraybrown@gmail.com>2024-02-02 18:39:57 +0000
commitd666f30475528ce7f50cc3dd92a1693241083fe8 (patch)
tree5b443f79a7100f2db735853335df81d9a7b95cc3 /hosts/nixpad/hardware-configuration.nix
parentea3485f5c5dac7f89562db741bf981b2b743d01c (diff)
major refactor (treewide amongst general cleaning based on my modified dots (with help from notashelf) - perks 1: it works
Diffstat (limited to 'hosts/nixpad/hardware-configuration.nix')
-rw-r--r--hosts/nixpad/hardware-configuration.nix50
1 files changed, 28 insertions, 22 deletions
diff --git a/hosts/nixpad/hardware-configuration.nix b/hosts/nixpad/hardware-configuration.nix
index e326b0c..3588111 100644
--- a/hosts/nixpad/hardware-configuration.nix
+++ b/hosts/nixpad/hardware-configuration.nix
@@ -1,39 +1,45 @@
# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
-
{
- imports =
- [ (modulesPath + "/installer/scan/not-detected.nix")
- ];
+ config,
+ lib,
+ pkgs,
+ modulesPath,
+ ...
+}: {
+ imports = [
+ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = ["xhci_pci" "nvme" "uas" "sd_mod" "rtsx_usb_sdmmc"];
+ boot.initrd.kernelModules = [];
+ boot.kernelModules = ["kvm-intel"];
+ boot.extraModulePackages = [];
- boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ata_piix" "usb_storage" "sd_mod" "sdhci_pci" ];
- boot.initrd.kernelModules = [ ];
- boot.kernelModules = [ "kvm-intel" ];
- boot.extraModulePackages = [ ];
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/81d5eb4d-ed55-446c-8c99-048dfb214f9d";
+ fsType = "ext4";
+ };
- fileSystems."/" =
- { device = "/dev/disk/by-uuid/79fd353d-4e05-44fd-9e10-e57b08c140f0";
- fsType = "ext4";
- };
+ boot.initrd.luks.devices."luks-6251bba4-3361-4923-8d83-812cc3162b3e".device = "/dev/disk/by-uuid/6251bba4-3361-4923-8d83-812cc3162b3e";
- fileSystems."/boot/efi" =
- { device = "/dev/disk/by-uuid/AA53-B6CE";
- fsType = "vfat";
- };
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/89AE-5193";
+ fsType = "vfat";
+ };
- swapDevices =
- [ { device = "/dev/disk/by-uuid/92e64b37-f558-4333-bfb0-0e4bfe6e91c0"; }
- ];
+ swapDevices = [
+ {device = "/dev/disk/by-uuid/d3f0c084-4a4d-4175-a0e6-94fbe8459614";}
+ ];
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
# (the default) this is the recommended approach. When using systemd-networkd it's
# still possible to use this option, but it's recommended to use it in conjunction
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp0s25.useDHCP = lib.mkDefault true;
- # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
+ # networking.interfaces.wlp0s20f3.useDHCP = lib.mkDefault true;
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;