aboutsummaryrefslogtreecommitdiff
path: root/hosts/default.nix
diff options
context:
space:
mode:
authorNotAShelf <itsashelf@gmail.com>2023-04-25 23:10:57 +0300
committerGitHub <noreply@github.com>2023-04-25 21:10:57 +0100
commit243a9339f041f62c1b5d8c05b415b126349c95b5 (patch)
tree315d2fafb2ed592e13ebd299f31fcd5d74e2127e /hosts/default.nix
parent4b0c88736979fe2cb8e98e8e0ae12caf7e876141 (diff)
reflopactor (#1)
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
new file mode 100644
index 0000000..36a8b85
--- /dev/null
+++ b/hosts/default.nix
@@ -0,0 +1,23 @@
+{
+ nixpkgs,
+ self,
+ outputs,
+ ...
+}: let
+ inputs = self.inputs;
+
+ home-manager = inputs.home-manager.nixosModules.home-manager;
+ homes = ../homes;
+in {
+ nixbox = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs outputs;};
+ modules = [
+ # this list defines which files will be imported to be used as "modules" in the system config
+ ./nixbox/configuration.nix
+
+ # use the nixos-module for home-manager
+ home-manager
+ homes
+ ];
+ };
+}