aboutsummaryrefslogtreecommitdiff
path: root/homes/floppydisk/ssh.nix
diff options
context:
space:
mode:
authorFrankie B <git@diskfloppy.me>2024-02-07 01:40:31 +0000
committerFrankie B. <git@diskfloppy.me>2024-02-07 01:42:25 +0000
commit1c68fd4369de1980b7f3c130edee8b0ef67f743c (patch)
treed931a7fd3c05b65c155754647f0516c32960b84a /homes/floppydisk/ssh.nix
parentd666f30475528ce7f50cc3dd92a1693241083fe8 (diff)
Multiple cfg updates
* Add hyprpaper config * Remove old monitor configs * Update waybar to use hyprland workspaces * Format waybar * Enable networkmanager * Remove KDE Plasma
Diffstat (limited to 'homes/floppydisk/ssh.nix')
-rw-r--r--homes/floppydisk/ssh.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/homes/floppydisk/ssh.nix b/homes/floppydisk/ssh.nix
new file mode 100644
index 0000000..99e77c5
--- /dev/null
+++ b/homes/floppydisk/ssh.nix
@@ -0,0 +1,17 @@
+{
+ nixosConfig,
+ config,
+ lib,
+ ...
+}: let
+ _1passwordAgent = {
+ enable = nixosConfig != {} && nixosConfig.programs._1password-gui.enable && nixosConfig.programs._1password-gui.sshAgent;
+ path = "${config.home.homeDirectory}/.1password/agent.sock";
+ };
+in {
+ programs.ssh = {
+ enable = true;
+ forwardAgent = _1passwordAgent.enable;
+ extraConfig = lib.optionalString _1passwordAgent.enable "IdentityAgent ${_1passwordAgent.path}";
+ };
+} \ No newline at end of file