aboutsummaryrefslogtreecommitdiff
path: root/homes/default.nix
diff options
context:
space:
mode:
authorNotAShelf <itsashelf@gmail.com>2023-04-25 23:10:57 +0300
committerGitHub <noreply@github.com>2023-04-25 21:10:57 +0100
commit243a9339f041f62c1b5d8c05b415b126349c95b5 (patch)
tree315d2fafb2ed592e13ebd299f31fcd5d74e2127e /homes/default.nix
parent4b0c88736979fe2cb8e98e8e0ae12caf7e876141 (diff)
reflopactor (#1)
Diffstat (limited to 'homes/default.nix')
-rw-r--r--homes/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/homes/default.nix b/homes/default.nix
new file mode 100644
index 0000000..267a3d0
--- /dev/null
+++ b/homes/default.nix
@@ -0,0 +1,19 @@
+{
+ inputs,
+ self,
+ outputs,
+ ...
+}: {
+ home-manager = {
+ useUserPackages = true;
+ useGlobalPkgs = true;
+ extraSpecialArgs = {
+ inherit inputs self outputs;
+ };
+ users = {
+ # TODO: "base" user that will be used by default is there is no defined
+ # home directory for the user
+ floppydisk = ./floppydisk;
+ };
+ };
+}