aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorNotAShelf <itsashelf@gmail.com>2023-04-26 00:15:52 +0300
committerFrankie B <frankieraybrown@gmail.com>2023-04-25 22:17:52 +0100
commitdc4f427d0fad10a53f22cd3f638319e1588e32b9 (patch)
tree5dd164eb68ccf6cc52d77c9165a5cb18565e80c4 /flake.nix
parenteee02f7a00d51c764fe9c9aaaa304679c4fc172f (diff)
separate stable and unstable pkgs
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index c9ba154..9acecc3 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,11 +3,8 @@
inputs = {
# Nixpkgs
- nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
- # You can access packages and modules from different nixpkgs revs
- # at the same time. Here's an working example:
- nixpkgs-unstable.url = "github:nixos/nixpkgs/nixos-unstable";
- # Also see the 'unstable-packages' overlay at 'overlays/default.nix'.
+ nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable"; # based unstable packages
+ nixpkgs-master.url = "github:nixos/nixpkgs/master"; # cringe stable packages
# Home manager
home-manager = {
@@ -15,6 +12,12 @@
inputs.nixpkgs.follows = "nixpkgs";
};
+ # neovim-flake
+ neovim-flake = {
+ url = "github:notashelf/neovim-flake";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+
# TODO: Add any other flake you might need
# nixos-hardware.url = "github:nixos/nixos-hardware";
};