aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..9525915
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,10 @@
+# Shell for bootstrapping flake-enabled nix and home-manager
+# You can enter it through 'nix develop' or (legacy) 'nix-shell'
+
+{ pkgs ? (import ./nixpkgs.nix) { } }: {
+ default = pkgs.mkShell {
+ # Enable experimental features without having to specify the argument
+ NIX_CONFIG = "experimental-features = nix-command flakes";
+ nativeBuildInputs = with pkgs; [ nix home-manager git ];
+ };
+}