aboutsummaryrefslogtreecommitdiff
path: root/nixos/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/hardware-configuration.nix')
-rw-r--r--nixos/hardware-configuration.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nixos/hardware-configuration.nix b/nixos/hardware-configuration.nix
new file mode 100644
index 0000000..dd00939
--- /dev/null
+++ b/nixos/hardware-configuration.nix
@@ -0,0 +1,10 @@
+# This is just an example, you should generate yours with nixos-generate-config and put it in here.
+{
+ fileSystems."/" = {
+ device = "/dev/sda1";
+ fsType = "ext4";
+ };
+
+ # Set your system kind (needed for flakes)
+ nixpkgs.hostPlatform = "x86_64-linux";
+}