aboutsummaryrefslogtreecommitdiff
path: root/hosts/sunfish/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/sunfish/hardware-configuration.nix')
-rw-r--r--hosts/sunfish/hardware-configuration.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/hosts/sunfish/hardware-configuration.nix b/hosts/sunfish/hardware-configuration.nix
new file mode 100644
index 0000000..82ab936
--- /dev/null
+++ b/hosts/sunfish/hardware-configuration.nix
@@ -0,0 +1,45 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{
+ config,
+ lib,
+ pkgs,
+ modulesPath,
+ ...
+}: {
+ imports = [
+ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = ["xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" "sr_mod"];
+ boot.initrd.kernelModules = [];
+ boot.kernelModules = ["kvm-intel"];
+ boot.extraModulePackages = [];
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/8050c8ec-0625-498d-99f6-198d58f65c79";
+ fsType = "ext4";
+ };
+
+ fileSystems."/efi" = {
+ device = "/dev/disk/by-uuid/4EAD-75BA";
+ fsType = "vfat";
+ options = ["fmask=0077" "dmask=0077"];
+ };
+
+ swapDevices = [
+ {device = "/dev/disk/by-uuid/1a21fac9-5a8e-4ae1-ae44-5049211d56fc";}
+ ];
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp3s0.useDHCP = lib.mkDefault true;
+ # networking.interfaces.tailscale0.useDHCP = lib.mkDefault true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}