aboutsummaryrefslogtreecommitdiff
path: root/hosts/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
new file mode 100644
index 0000000..36a8b85
--- /dev/null
+++ b/hosts/default.nix
@@ -0,0 +1,23 @@
+{
+ nixpkgs,
+ self,
+ outputs,
+ ...
+}: let
+ inputs = self.inputs;
+
+ home-manager = inputs.home-manager.nixosModules.home-manager;
+ homes = ../homes;
+in {
+ nixbox = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs outputs;};
+ modules = [
+ # this list defines which files will be imported to be used as "modules" in the system config
+ ./nixbox/configuration.nix
+
+ # use the nixos-module for home-manager
+ home-manager
+ homes
+ ];
+ };
+}