aboutsummaryrefslogtreecommitdiff
path: root/hosts/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
index 36a8b85..e12b1f6 100644
--- a/hosts/default.nix
+++ b/hosts/default.nix
@@ -20,4 +20,16 @@ in {
homes
];
};
+
+ nixpad = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs outputs;};
+ modules = [
+ # this list defines which files will be imported to be used as "modules" in the system config
+ ./nixpad/configuration.nix
+
+ # use the nixos-module for home-manager
+ home-manager
+ homes
+ ];
+ };
}