aboutsummaryrefslogtreecommitdiff
path: root/home-manager/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/home.nix')
-rw-r--r--home-manager/home.nix73
1 files changed, 73 insertions, 0 deletions
diff --git a/home-manager/home.nix b/home-manager/home.nix
new file mode 100644
index 0000000..46f555d
--- /dev/null
+++ b/home-manager/home.nix
@@ -0,0 +1,73 @@
+# This is your home-manager configuration file
+# Use this to configure your home environment (it replaces ~/.config/nixpkgs/home.nix)
+{
+ inputs,
+ outputs,
+ lib,
+ config,
+ pkgs,
+ ...
+}: {
+ # You can import other home-manager modules here
+ imports = [
+ # If you want to use modules your own flake exports (from modules/home-manager):
+ # outputs.homeManagerModules.example
+
+ # Or modules exported from other flakes (such as nix-colors):
+ # inputs.nix-colors.homeManagerModules.default
+
+ # You can also split up your configuration and import pieces of it here:
+ # ./nvim.nix
+ ];
+
+ nixpkgs = {
+ # You can add overlays here
+ overlays = [
+ # Add overlays your own flake exports (from overlays and pkgs dir):
+ outputs.overlays.additions
+ outputs.overlays.modifications
+ outputs.overlays.unstable-packages
+
+ # You can also add overlays exported from other flakes:
+ # neovim-nightly-overlay.overlays.default
+
+ # Or define it inline, for example:
+ # (final: prev: {
+ # hi = final.hello.overrideAttrs (oldAttrs: {
+ # patches = [ ./change-hello-to-hi.patch ];
+ # });
+ # })
+ ];
+ # Configure your nixpkgs instance
+ config = {
+ # Disable if you don't want unfree packages
+ allowUnfree = true;
+ # Workaround for https://github.com/nix-community/home-manager/issues/2942
+ allowUnfreePredicate = _: true;
+ };
+ };
+
+ home = {
+ username = "floppydisk";
+ homeDirectory = "/home/floppydisk";
+ };
+
+ # Add stuff for your user as you see fit:
+ programs.neovim.enable = true;
+ home.packages = with pkgs; [steam vscode _1password-gui _1password neofetch microsoft-edge webcord-vencord];
+
+ # Enable home-manager and git
+ programs.home-manager.enable = true;
+
+ programs.git = {
+ enable = true;
+ userName = "Frankie B.";
+ userEmail = "git@diskfloppy.me";
+ };
+
+ # Nicely reload system units when changing configs
+ systemd.user.startServices = "sd-switch";
+
+ # https://nixos.wiki/wiki/FAQ/When_do_I_update_stateVersion
+ home.stateVersion = "22.11";
+}