aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix32
1 files changed, 11 insertions, 21 deletions
diff --git a/flake.nix b/flake.nix
index 9329055..c9ba154 100644
--- a/flake.nix
+++ b/flake.nix
@@ -10,15 +10,13 @@
# Also see the 'unstable-packages' overlay at 'overlays/default.nix'.
# Home manager
- home-manager.url = "github:nix-community/home-manager";
- home-manager.inputs.nixpkgs.follows = "nixpkgs";
+ home-manager = {
+ url = "github:nix-community/home-manager";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
# TODO: Add any other flake you might need
- # hardware.url = "github:nixos/nixos-hardware";
-
- # Shameless plug: looking for a way to nixify your themes and make
- # everything match nicely? Try nix-colors!
- # nix-colors.url = "github:misterio77/nix-colors";
+ # nixos-hardware.url = "github:nixos/nixos-hardware";
};
outputs = {
@@ -54,26 +52,18 @@
);
# Your custom packages and modifications, exported as overlays
- overlays = import ./overlays {inherit inputs;};
+ # overlays = import ./overlays {inherit inputs;}; # TODO: only use overlays when you understand what tthey do
+
# Reusable nixos modules you might want to export
# These are usually stuff you would upstream into nixpkgs
- nixosModules = import ./modules/nixos;
+ # nixosModules = import ./modules/public/nixos;
# Reusable home-manager modules you might want to export
# These are usually stuff you would upstream into home-manager
- homeManagerModules = import ./modules/home-manager;
+ # homeManagerModules = import ./modules/public/home-manager;
# NixOS configuration entrypoint
# Available through 'nixos-rebuild --flake .#your-hostname'
- nixosConfigurations = {
- # FIXME replace with your hostname
- nixbox = nixpkgs.lib.nixosSystem {
- specialArgs = {inherit inputs outputs;};
- modules = [
- # > Our main nixos configuration file <
- ./nixos/hosts/nixbox/configuration.nix
- ];
- };
- };
+ nixosConfigurations = import ./hosts {inherit nixpkgs self outputs;};
# Standalone home-manager configuration entrypoint
# Available through 'home-manager --flake .#your-username@your-hostname'
@@ -83,7 +73,7 @@
extraSpecialArgs = {inherit inputs outputs;};
modules = [
# > Our main home-manager configuration file <
- ./home-manager/home.nix
+ ./homes/floppydisk
];
};
};