aboutsummaryrefslogtreecommitdiff
path: root/common/nvim-flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/nvim-flake.nix')
-rw-r--r--common/nvim-flake.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/common/nvim-flake.nix b/common/nvim-flake.nix
new file mode 100644
index 0000000..daed404
--- /dev/null
+++ b/common/nvim-flake.nix
@@ -0,0 +1,23 @@
+{inputs, ...}: {
+
+ imports = [ inputs.neovim-flake.homeManagerModules.default ];
+ # enable programs
+ programs = {
+ neovim-flake = {
+ enable = true;
+ settings = {
+ vim.languages = {
+ nix.enable = true;
+ nix.lsp.enable = true;
+ ts.enable = true;
+ python.enable = true;
+ html.enable = true;
+ };
+ vim.lsp = {
+ enable = true;
+ };
+ };
+ };
+ # ... add more programs as you see fit
+ };
+}