aboutsummaryrefslogtreecommitdiff
path: root/common/nvim-flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/nvim-flake.nix')
-rw-r--r--common/nvim-flake.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/common/nvim-flake.nix b/common/nvim-flake.nix
deleted file mode 100644
index daed404..0000000
--- a/common/nvim-flake.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{inputs, ...}: {
-
- imports = [ inputs.neovim-flake.homeManagerModules.default ];
- # enable programs
- programs = {
- neovim-flake = {
- enable = true;
- settings = {
- vim.languages = {
- nix.enable = true;
- nix.lsp.enable = true;
- ts.enable = true;
- python.enable = true;
- html.enable = true;
- };
- vim.lsp = {
- enable = true;
- };
- };
- };
- # ... add more programs as you see fit
- };
-}