aboutsummaryrefslogtreecommitdiff
path: root/hosts/default.nix
diff options
context:
space:
mode:
authorFrankie B <git@diskfloppy.me>2023-04-26 02:16:53 +0100
committerFrankie B <git@diskfloppy.me>2023-04-26 02:16:53 +0100
commit352c1856875c14437d3db7e3e34da5c5a1ddcc8d (patch)
tree9159bb4291dbc3e5264e2d925b36a8a92687faee /hosts/default.nix
parentd75b9120706eb7c3ada64fe0e19f029dfe723d0d (diff)
Add nixpad configuration
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
index 36a8b85..e12b1f6 100644
--- a/hosts/default.nix
+++ b/hosts/default.nix
@@ -20,4 +20,16 @@ in {
homes
];
};
+
+ nixpad = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs outputs;};
+ modules = [
+ # this list defines which files will be imported to be used as "modules" in the system config
+ ./nixpad/configuration.nix
+
+ # use the nixos-module for home-manager
+ home-manager
+ homes
+ ];
+ };
}