aboutsummaryrefslogtreecommitdiff
path: root/homes/floppydisk/waybar.nix
diff options
context:
space:
mode:
authorFrankie B <git@diskfloppy.me>2023-09-02 21:27:24 +0100
committerFrankie B <git@diskfloppy.me>2023-09-02 21:27:24 +0100
commit1e0f3fbf9c1d0a8d28afb87d82c9e42a685796b2 (patch)
treed5b3c39de8f61847554c2899cc8b452cacb68e31 /homes/floppydisk/waybar.nix
parentf63fa74e6af4ac018688d710e186765d973723a1 (diff)
Update waybar config
Diffstat (limited to 'homes/floppydisk/waybar.nix')
-rw-r--r--homes/floppydisk/waybar.nix41
1 files changed, 10 insertions, 31 deletions
diff --git a/homes/floppydisk/waybar.nix b/homes/floppydisk/waybar.nix
index cf04415..281959b 100644
--- a/homes/floppydisk/waybar.nix
+++ b/homes/floppydisk/waybar.nix
@@ -3,33 +3,22 @@
layer = "top";
position = "top";
height = 27;
- margin = "7";
fixed-center = true;
modules-left = [
- "wlr/workspaces"
+ "custom/notification"
"custom/sep"
"tray"
- "custom/updates"
];
modules-center = [
- "clock"
- "sep"
- "custom/notification"
+ "wlr/workspaces"
];
modules-right = [
"battery"
- "custom/sep_r"
"cpu"
- "custom/sep_r"
"memory"
- "custom/sep_r"
- "disk"
- "custom/sep_r"
"pulseaudio"
- "custom/sep_r"
"network"
- "custom/sep_r"
- "custom/launcher"
+ "clock"
];
"custon/sep_r" = {
@@ -66,7 +55,7 @@
disable-scroll = false;
all-outputs = true;
format = "{icon}";
- active-only = true;
+ active-only = false;
format-icons = {
"1" = "I";
"2" = "II";
@@ -119,9 +108,9 @@
"clock" = {
timezone = "Europe/London";
- format = "{: %H:%M}";
- format-alt = "{: %H:%M  %d/%m/%Y}";
- tooltip-format = "{: %H:%M  %d/%m/%Y}";
+ format = "{: %H:%M}";
+ format-alt = "{: %H:%M  %d/%m/%Y}";
+ tooltip-format = "{: %H:%M  %d/%m/%Y}";
today-format = "<span color='#aaaaaa'><b><u>{}</u></b></span>";
calendar-weeks-pos = "right";
format-calendar = "<span color='#aaaaaa'><b><u>{}</u></b></span>";
@@ -166,19 +155,8 @@
"pulseaudio" = {
on-click = "pavucontrol";
- format = "{icon}{volume}% {format_source}";
- format-bluetooth = "{icon}{volume}% {format_source}";
- format-bluetooth-muted = "{icon} {format_source}";
- format-muted = " {format_source}";
- format-source = " {volume}%";
- format-source-muted = " ";
+ format = "{icon}{volume}%";
format-icons = {
- "headphone" = "";
- "hands-free" = "";
- "headset" = "";
- "phone" = "";
- "portable" = "";
- "car" = "";
"default" = [" " " " " "];
};
};
@@ -195,4 +173,5 @@
on-click = "wlogout";
};
};
-} \ No newline at end of file
+}
+