aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorFrankie B <git@diskfloppy.me>2023-08-09 14:49:06 +0100
committerFrankie B <git@diskfloppy.me>2023-08-09 14:49:06 +0100
commitf240b64f25ff5418eb39151fa3de795b002848c4 (patch)
treeae23648a675febfc97ff538518a1d188cbf75cca /flake.nix
parentc48a34747e46be6baa21eb0618c3b329ebfe5887 (diff)
hyprland-ification
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 6f780ab..d96d4d8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -23,12 +23,16 @@
url = "github:notashelf/arrpc-flake";
inputs.nixpkgs.follows = "nixpkgs";
};
+
+ # hyprland
+ hyprland.url = "github:hyprwm/Hyprland";
};
outputs = {
self,
nixpkgs,
home-manager,
+ hyprland,
...
} @ inputs: let
inherit (self) outputs;
@@ -78,6 +82,8 @@
pkgs = nixpkgs.legacyPackages.x86_64-linux; # Home-manager requires 'pkgs' instance
extraSpecialArgs = {inherit inputs outputs;};
modules = [
+ hyprland.homeManagerModules.default
+ {wayland.windowManager.hyprland.enable = true;}
# > Our main home-manager configuration file <
./homes/floppydisk
];